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View, Copy and Paste Email Headers for Email Trace
If you want to conduct a reverse email lookup search or trace an email address to locate the name and
address of the person that sent it, you will need to be able to provide the full email header and the email
address.
The instructions below should help you view and copy (extract) headers from many of the popular email
programs. Once you are able to view and copy the full email header you can paste them into any online
form or document you want.
Hotmail:
Log into Hotmail.
Click on "Options" tab on the top navigation bar.
Click on the "Mail" link on the navigation bar on the left.
Click on the "Mail Display Settings" link.
Change the "Message Headers" option to "Full".
Click the "OK" button.
Yahoo Mail:
Log into your Yahoo! Mail account.
Click the "Options" link on the navigation bar.
Click the "General Preferences" link.
Go to the paragraph titled Messages and Locate the Show Headers heading and select "All."
Click the "Save" button to put your new settings into effect.
Once this setting is saved, go back and open your email and you should view the headers.
AOL Mail:
If the email is sent from anywhere OTHER then AOL, and you are receiving it in AOL, then open the
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email you want to trace, or have your client open the email, and look for the link Details. This link is
usually just below the To:email in the email message. If the email is sent from an AOL user to another
AOL user then our Reverse AOL Screenname search can get you the sender's information.
Gmail:
Log into your Gmail Account
Open the Email whose headers you want to view
Click on the more options link in the message next to the date of the email.
If the link says hide options then do not worry you have already clicked on the more options link.
Now click the link called show original.
This will bring up a new window with headers and the body of the message.
Thunderbird (Firefox - Mozilla):
To view email headers
Go to "View"
Then go to Headers
Select "All" to view email headers.
XtraMail:
Log into XtraMail
Click on "Options" in the Left-hand navigation bar.
Click the "Display" button.
Change the "Message Headers" option to "Full".
Click the "OK" button.
Outlook Express 4, 5 and 6:
Double click the message to open in its own window:
Click "File" on the menu
Click "Properties" from the File sub menu
Click the "Details" tab
Click "Message Source"
Highlight, copy, and paste everything from this window (Ctrl-A, Ctrl-C)
NOTE: With Viruses, Worms and Trojans being spread via email, many users now work with the preview
screen in Outlook Express turned off. Viewing email in the preview screen is no different than opening
the message. If the email has malicious content, it may execute in the preview screen.
Use the following instructions to obtain the full message source if you have the preview panel turned off:
Using the keyboard:
Highlight the message in the folder
Press ALT & Enter - this will open a message information window
Press Ctrl & Tab - this changes to the "Details" tab
Press Alt & M - the opens the message source
Press Ctrl & A - to select all the text
Press Ctrl & C - to copy the selected text to the clipboard
Press Alt & F4 - to close the message source window
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Press the Esc key - to close the information window
Outlook 97:
Microsoft Outlook 97 may require an update called the Internet Mail Enhancement Patch in order to
display the email headers AT ALL.
Outlook 98, 2000 & 2003 (maybe 2007 but we have not tested):
Double click the message to open in its own window:
Under the View menu select Options
Select and Copy all the Text in the Internet Headers window.
Text is ready to Paste into online form for search
Close the options window
Outlook Express for Macintosh:
Select the email.
From the View menu, choose Source.
A new window will appear containing the email with full headers.
Press command + A, to select all, then command + C to copy.
Microsoft Exchange:
For complete headers and message source using Microsoft Exchange
Click the "File" menu
Click "Properties"
Click the "Details" tab
Click "Message Source"
Highlight, copy, and paste everything from the "Message Source" window (Ctrl-A, Ctrl-C)
Microsoft Entourage (Office X for Mac):
After clicking on the message, select "Source" from the View menu
A new window will open showing the full message source with complete headers.
Copy and paste
Mac OS X:
To get the full message source:
Select a message
Select menu item Message, Show, Raw Source.
Click on the resulting text
Click Edit, Select All, then Edit, Copy
Paste
Netscape:
Preferred method: Click on the "View" menu, then "Page Source," (ctrl-U in windows, meta-U in
UNIX,?-U on the Mac) then copy the contents of the window (Ctrl-A, Ctrl-C windows).
Old versions: Click on the "View" menu, then "Headers," then "All."
Note: This method will not work correctly with HTML.
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Eudora:
Note: Using the cut and paste to the web form method is the only option available to Eudora users.
Eudora for the Mac:
Open the email and click the button on the upper left hand corner of the message.
This shows the extended headers. Select the whole message including headers and paste.
Eudora for the PC:
There are 2 slightly different methods depending on whether the mail contains HTML or not.
To prepare for HTML email you should turn off the use of Microsoft's HTML viewer.
Click Tools, then Options, then Viewing Mail.
Uncheck the box labeled "Use Microsoft's viewer."
How to know if it's HTML mail:
Open the email and look near the bottom of the headers (see below for revealing headers) for a line like
the following:
Content-Type: text/html
You can frequently spot HTML email because it does not look like plain text. It usually has some font
effects (like bold or underlines), some graphics or pictures. It's not always true so you have to take a
quick look at the headers.
Eudora for the PC - non-HTML mail:
Double click on the subject line to open the email.
Click the button to reveal the headers.
Place your cursor anywhere in the body of the email and select the entire message (Edit/Select All or CtrlA)
Copy the entire email (right click and click copy OR Ctrl/C OR Edit/Copy)
Paste (right click/paste or Ctrl/V).
Eudora for the PC - HTML mail:
Open the email and click the button to reveal the headers.
Highlight the headers only. Copy and paste the headers.
Hit enter twice after the pasted headers to force a blank line after the headers.
Back in Eudora window, place your cursor anywhere in the body of the message and right click and click
"view source". A new window will open.
In the new window, select all (as above) and copy the contents of the new window.
Ready to Paste
Pine:
If the feature is enabled, you simply press "H" to toggle full headers. If the feature is not enabled, you
must enable it first: From the main menu, press (S)etup, (C)onfig. Scroll down about 40 lines to the
option labeled "enable-full-header-cmd." Press [ENTER]. Press (E)xit, (Y)es - to save. Then you can
return to the message window and use "H" to display the headers.
Lotus Notes (v.4.x and v.5.x):
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Open the email, click on "Actions" then on "Delivery Information."
Now you have to pick out the internet-style mail header information from the window that appears when
you select Delivery Information.
Lotus Notes v.4.x:
Look for the first line that begins with "Received". There should be a blank line just above it. Then, scroll
down to the next blank line. The stuff in-between the two blank lines are the headers you need.
Lotus Notes v.5.x:
Look for the separator line that reads
-------- Additional Header ------.
Select everything from there down to the next separator line, usually
-------- Routing Information -----The stuff in between the two separator lines are the headers you need.
Lotus Notes v.5.x (easier method):
Open your inbox
Highlight the message that you wish to get header information for.
Choose File -> Export...
Type in a filename, leave the type as "Structured Text" and click Export
From the Dialog Box that comes up, choose "Selected Documents" and click OK
Now you can open that message you saved in WordPad and Cut and Paste it.
Pegasus Mail:
In the New Mail or other folder window:
Right click the message, and select Message Properties.
In the right hand column uncheck the box beside Contains HTML data.
Click OK. That should allow you to see the message as a text message only.
Click Ctrl-H to bring up the full headers.
Another way:
Highlight the HTML in the new mail folder
Open a new email message
Drag the HTML onto the new message
In the dialog that appears select "Show All Headers"
Highlight the entire message and then copy to clipboard
Ready to Paste
Claris Emailer - Version 2.0 and higher:
Use the "Show Long Headers" option in the "Mail" menu while you have the message open.
Claris Emailer - Versions earlier than 2.0:
Click the blue triangle near the "from" information to show additional message information, then click the
"Show Original Headers..." button to bring up the full header info.
kmail (KDE Desktop):
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In the KDE Mail Client that comes with the KDE desktop for Linux, select Message, View Source. Copy
and paste the text from the "Message as Plain Text" window.
GNU/Emacs integrated email:
Press the keys 'W', then 'v' in the summary or mail buffer.
Another method of temporarily switching to ALL headers is by pressing "Ctrl-u g" on the article in the
summary buffer.
Mail Warrior:
To get full "message source"
When viewing the message, click File, then Save Message As.
A standard save window will appear.
Save the message as a .txt file (document.txt).
Open the file you created, select all (ctrl-A) and copy (ctrl-c).
And paste (ctrl-v).
These instructions written for v.3.56.
Juno Version 4+:
On the drop down menu "Options", choose "Email Options..."• (press ctrl-E) Under "Show Message
Headers", select the "full" option. Click the OK button to save the setting.
Juno version 4+ can display MIME and HTML email, but does not provide a way of viewing the HTML
Source for the message within Juno.
To get the full source, including HTML codes:
In the Juno mail client, click "file" and then "Save Message as Text File..."• (CTRL-T).
Give the file a name which you will remember (you can save a temporary files to the desktop).
Double-click on the resulting file and then cut-and-paste the contents.
Mutt:
To get mutt (the mail user agent) to forward the full headers (not display them for viewing), use the
command "unset forward decode" in your rc file or directly in the command interface.
The Bat!:
To get the full text of an HTML message from TheBat email software in preparation for pasting it:
Message -> Save As -> Save as Type - I
Select Unix Mailboxes[*.mbx]
Open the file in your preferred editor, then simply cut and paste.
For The Bat! v1.53bis:
Select the message in question
Click on the "Messages" menu
Select "View Source"
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Alternatively, you may push F9 instead of the last two steps.
Pronto mail (GTK/UNIX):
Click "Message", then "View Source"
Highlight the message source as normal with the mouse
Copy using Control + C
Paste
StarOffice :
Right click on the container name in the explorer panel (either a top-level mail box or a specific mail
folder).
Select the Properties item from the pop-up menu.
In the properties notebook, select the Headers tab.
Click the "All" button on the right.
Press "OK" and you're done, the complete header is available in the header panel and can be
selected/pasted.
Novell GroupWise:
Open the message
In the message window select: File > Attachments > View
Select the Mime.822 attachment
Blitzmail:
With the message open, go to the Options menu and choose Verbose Header.
This will put the full header inside the upper pane of the message's window.
Forte Agent versions 1.5 to 1.8:
Press CTRL-R to display in RAW mode, then CTRL-A and CTRL-C
Don't forget to press CTRL-R again to display in normal mode after you do this
Ximian Evolution:
http://www.Ximian.com/products/ximian_evolution/
Go to the "View" menu, select "Message Display" and click on "Show Full Headers".
Sylpheed:
Sylpheed is an email client for Linux, BSD and Unix systems and offers three ways to view the full
source code of messages:
Option 1: Select the email
Right click and mouse-over "View"
Select "Source" from the popup menu
Option 2:
Select the email
Left click on the "View" menu
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Select "View Source"
Option 3:
Select the email
Press Ctrl-U (default keymap setting)
Web-Based Email Software
Hotmail:
To see the full, untangled headers in Hotmail:
First, configure your options:
Click on "Options." In the "Additional Options" column, click on "Mail Display Options" and find the
item "Message Headers." Choose "Advanced" and click the "OK" button. Headers will appear at the top
of emails.
Yahoo Mail:
First you must turn on "Full Headers". From your Yahoo mail account, click on "Mail Preference". Scroll
down the page to "Message Headers" and click on the "all" radio button. Save your preferences at the
bottom of the page.
View the message. If the message is in plain text, copying from this page and pasting it will work.
If the message is HTML, a two stepped process must be used:
View the message and copy the complete headers. Ready to Paste.
Excite web-mail:
Sign in to your email account.
Click on Preferences on the Email home page
Click on Email Preferences
Check the box to display headers
Click on Save
You can then see the headers in all messages in your folders.
Netscape Webmail:
While viewing the message, click on the yellow triangle to the right of the brief message headers. This
will display the full headers along with the message body, which can be cut and pasted
To close the full headers and return to brief headers, click the yellow triangle again.
Blitzmail:
After opening the message, click on the Verbose Header link at the top of the window.
Operamail:
Choose Options and enable [x] Show Message Headers in Body of Message
Lycos Mail (mailcity.com):
When viewing an individual message, click on the tool bar menu item above the message "All Headers".
Highlight and copy the complete message from the viewing window and paste it.
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Onebox.com:
Click on the subject of the email in your inbox or other folder. This displays the message.
At the top of the message you will see the following links in the message frame right above the "reply"
buttons:
[folder name]: Prev Next: Download
Select "Download" from the above.
A new browser window will appear with both the headers and the message text.
Simply copy all the text and paste it.
Outlook Web Access:
Only when accessed through http://mymail.outlookmail.com/exchange/logon.asp)
Left click on the letter you want to open and click on properties
When that opens click on the details tab, then on message source
This will open the email so the full headers will be available for viewing
Select and copy the text then paste it.
If you find any exceptions or corrections, please leave comments in this Article and we will do our best to
keep this updated.
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